Mobili versija | Apie | Visos naujienos | RSS | Kontaktai | Paslaugos
 
Jūs esate čia: Pradžia » Visos temos » Technologijos » IT

Atrastas milžiniškas saugumo defektas, keliantis grėsmę dviem trečdaliams pasaulio serverių

2014-04-09 (14) Rekomenduoja   (0) Perskaitymai (1858)
    Share
Tai straipsnis iš rašinių ciklo. Peržiūrėti ciklo turinį

Kompiuterių saugumo analitikai aptiko kritinį defektą kriptografinėje programinėje įrangoje, kurią, manoma, naudoja du trečdaliai visų pasaulio serverių. Ši programinė įranga reikalinga tam, kad serveris identifikuotųsi galutiniam vartotojui ir apsaugotų nuo slaptažodžių, interneto bankininkystės duomenų bei kitos svarbios informacijos vagysčių, rašo arstechnica.com.

Įspėjimas apie „OpenSSL“ klaidą buvo publikuotas kartu su šios atviro kodo programinės įrangos 1.0.1g versijos išleidimu. „OpenSSL“ biblioteka yra naudojama pagal nutylėjimą „Apache“ ir „Nginx“ pagrindu veikiančiuose serveriuose, taip pat keliose operacinėse sistemose, elektroninio pašto ir greitųjų žinučių programose.

Dėl šios daugiau nei dvejus metus saugumo ekspertų nepastebėtos klaidos buvo įmanoma perimti skaitmeniniuose sertifikatuose saugomą privatų šifro raktą, per kurį interneto serveriai identifikuojasi galutiniam vartotojui ir šifruoja duomenis, keliaujančius tarp serverio bei vartotojo. Dar viena blogybė – kad pasinaudojus šia saugumo skyle serverio įrašuose nepaliekama jokių pėdsakų, taigi, neįmanoma nustatyt, nei kas šia klaida pasinaudojo, nei ar apskritai ja buvo naudojamasi. Tačiau įvertinus galimybę per šią skylę iškrapštyti šifro raktus, slaptažodžius ir kitus svarbius duomenis, kyla didelė rizika, kad šia skyle ateityje bus bandoma naudotis.

„Klaidos pavienėse programose ar bibliotekose pasitaiko ir būna ištaisomos naujose versijose. Tačiau ši klaida visam internetui atvėrė duris į didžiulį kiekį privačių raktų ir kitų paslapčių. Įvertinus tai, kad klaida egzistavo ilgą laiką, o pasinaudojimas ja nepalieka jokių pėdsakų, situaciją reikia vertinti itin rimtai“, - pirmadienį tinklaraštyje teigė „OpenSSL“ silpnybę aptikę ekspertai.

„Google“ ir programinės įrangos saugumo bendrovėje „Codenomicon“ dirbantys ekspertai teigė, jog net svetainėms atnaujinus „OpenSSL“ iki saugios versijos, pačios svetainės gali išlikti pažeidžiamos atakoms, mat egzistuoja grėsmė, kad programišiai šia skyle pasinaudojo jau anksčiau ir turi skaitmeninių sertifikatų privačius raktus, svetainių administravimo slaptažodžius ar autentifikavimo slapukus. Norint užsitikrinti saugumą, prarastą dėl dvejus metus egzistavusios skylės, taip pat reikėtų pakeisti visus iki šiol naudotus šifro raktus ir kitus autentifikavimo duomenis.

Kaip skelbia „Netcraft“, „OpenSSL“ yra populiariausia pasaulyje atviro kodo kriptografijos biblioteka, pagal nutylėjimą naudojama „Apache“ ir „Ngnix“ serveriuose, kuriuose veikia 66 proc. viso pasaulio svetainių. Be to, „OpenSSL“ naudojama ir įvairiose „Linux“ pagrindu sukurtose operacinėse sistemose - „Debian Wheezy“, „Ubuntu“, CENTOS, „Fedora“, „OpenBSD“, „FreeBSD“ ir „OpenSUSE“. Klaida egzistuoja visose „OpenSSL“ versijose nuo 1.0.1 iki 1.0.1f.

Klaida, kurios kodas yra CVE-2014-0160, programišiams suteikia galimybę iš serverio ar kliento kompiuterio su „OpenSSL“ atminties išgauti iki 64 kb duomenų bloką. „CloudFlare“ sistemų inžinierius Nickas Sullivanas sakė, kad jo įmonė iki šiol aiškinasi, kokia yra tikimybė, jog privatūs raktai galėtų būti šiuose atminties blokuose bei kaip tikėtina, kad programišiai šiuos duomenis pavogė iki klaidos paviešinimo. Nuo šio vertinimo rezultatų priklausys ir įmonės sprendimas keisti arba palikti TLS sertifikatą.

Tuo tarpu klaidą atradę saugumo ekspertai yra kategoriškesni: „Puolėme save iš išorės. Be jokios privilegijuotos informacijos ir slaptažodžių sugebėjome iš savęs pavogti slaptus raktus, naudotus mūsų X.509 sertifikatuose, vartotojų vardus ir slaptažodžius, greitąsias žinutes, elektroninius laiškus, verslo dokumentus ir susirašinėjimus“, rašoma jų tinklaraštyje.

Verta skaityti! Verta skaityti!
(5)
Neverta skaityti!
(0)
Reitingas
(0)
Visi šio ciklo įrašai:
Komentarai (14)
Komentuoti gali tik registruoti vartotojai
Naujausi įrašai

Įdomiausi

Paros
56(0)
51(0)
30(9)
27(1)
23(2)
20(0)
17(1)
12(2)
Savaitės
138(13)
132(12)
125(21)
86(7)
84(6)
Mėnesio
139(3)
139(0)
138(13)
134(2)
132(10)